(LØST) Rsync fejl, ADM 2.7.3

Herunder kan du indrapportere om fejl du har opdaget så mere tekniske brugere kan gå videre med det til Asustor
tubatuba
Bruger
Indlæg: 7
Tilmeldt: 30. jun 2017, 23:22

(LØST) Rsync fejl, ADM 2.7.3

Indlægaf tubatuba » 30. jun 2017, 23:27

Hej med jer.

Er der nogen her som har eller oplever fejl med rsync, har pt. 1 stk. AS5104T og 1 stk. AS-202TE og disse har jeg længe forsøgt at få til at køre imellem hinanden med den indbyggede rsync funktion.

Jeg har forsøgt begge vej, på begge servere og nedenstående fejl på begge

Warning: Permanently added '192.168.105.10' (ECDSA) to the list of known hosts.
rsync: connection unexpectedly closed (0 bytes received so far) [Receiver]
rsync error: error in rsync protocol data stream (code 12) at /asustor/branch2_7_2017_05_16/x86/source/rsync-3.0.9/io.c(605) [Receiver=3.0.9]

Hvis jeg fjerner SSH krypteringen så køre det fint, men da det skal en tur ud over nettet på sigt ønsker jeg ikke at køre rsync uden ssh.
Jeg har forsøgt at sætte rsync bruger op på begge maskiner, det hjælper heller ikke og ja har ikke haft held med at finde ud af hvad dette skyldes.

Nogen der har et godt bud på hvad det kan være?

Blueeyez
Site Admin
Indlæg: 95
Tilmeldt: 25. maj 2017, 13:17

Re: Rsync fejl

Indlægaf Blueeyez » 1. jul 2017, 12:59

Jeg forstår godt du benytter kryptering. Det gør heg selv både udefra og lokalt.
Er det seneste ADM 2.7 på begge maskiner?
Bruger du standard portene eller har du ændret portene?

Kan du mon oprette VPN forbindelse mellem dem? AS-5104T som VPN server og AS-202TE som klient?

Hvilken bruger forsøger du at bruge til rsync forbindelsen med kryptering?

Blueeyez
Site Admin
Indlæg: 95
Tilmeldt: 25. maj 2017, 13:17

Re: Rsync fejl

Indlægaf Blueeyez » 4. jul 2017, 10:29

Jeg har netop fået sat en test server op og får samme fejl. Jeg har netop sendt bolden videre til Asustor.

tubatuba
Bruger
Indlæg: 7
Tilmeldt: 30. jun 2017, 23:22

Re: Rsync fejl

Indlægaf tubatuba » 7. jul 2017, 19:50

Blueeyez skrev:Jeg forstår godt du benytter kryptering. Det gør heg selv både udefra og lokalt.
Er det seneste ADM 2.7 på begge maskiner?
Bruger du standard portene eller har du lndret portene?

Kan du mon oprette VPN forbindelse mellem dem? AS-5104T som VPN server og AS-202TE som klient?

Hvilken bruger forsøger du at bruge til rsync forbindelsen med kryptering?


Beklager det sene svar, men ja begge maskiner er opdateret med seneste version, bruger standart portene ja.

Har leget lidt med VPN, men jeg synes ikke det køre skide godt, det danner en del CPU load på den lille maskine, jeg bruger admin brugeren altså "admin" og password her til det er samme bruger jeg kan logge på ssh med på selve serveren.

tubatuba
Bruger
Indlæg: 7
Tilmeldt: 30. jun 2017, 23:22

Re: Rsync fejl

Indlægaf tubatuba » 7. jul 2017, 19:50

Blueeyez skrev:Jeg har netop fået sat en test server op og får samme fejl. Jeg har netop sendt bolden videre til Asustor.


Okay så jeg er ikke alene med dette problem, du har måske direkte adgang til asustor i forhold til fejl mv?

Blueeyez
Site Admin
Indlæg: 95
Tilmeldt: 25. maj 2017, 13:17

Re: Rsync fejl

Indlægaf Blueeyez » 7. jul 2017, 20:21

tubatuba skrev:Beklager det sene svar, men ja begge maskiner er opdateret med seneste version, bruger standart portene ja.

Har leget lidt med VPN, men jeg synes ikke det køre skide godt, det danner en del CPU load på den lille maskine, jeg bruger admin brugeren altså "admin" og password her til det er samme bruger jeg kan logge på ssh med på selve serveren.


Bruger du OpenVPN? Bruger selv VPN serveren og det virker rigtigt godt, men kommer jo os an på hvor meget du har kørende på din. Ja det kræver lidt cpu fra den, men det skyldes jo krypteirng og data der sendes og modtages ;-)

Hvilke porte har du åbnet for OpenVPN eller anden VPN type?

tubatuba skrev:
Blueeyez skrev:Jeg har netop fået sat en test server op og får samme fejl. Jeg har netop sendt bolden videre til Asustor.


Okay så jeg er ikke alene med dette problem, du har måske direkte adgang til asustor i forhold til fejl mv?


Noget i den stil ja :-)

tubatuba
Bruger
Indlæg: 7
Tilmeldt: 30. jun 2017, 23:22

Re: Rsync fejl

Indlægaf tubatuba » 7. jul 2017, 21:05

Ja brugte OpenVPN, synes bare ikke jeg kunne få det til at spille med adgang fra mit lokalnetværk ind på serveren lokalt når de var sat op i vpn dem imellem, og ja så gik det ikke vildt hurtigt men bruger det primært til en offsite backup..

Blueeyez
Site Admin
Indlæg: 95
Tilmeldt: 25. maj 2017, 13:17

Re: Rsync fejl

Indlægaf Blueeyez » 10. jul 2017, 09:58

Under Understøt krypteret overførsel via SSH skal du angive root som brugernavn. Kodeordet er det samme som ved admin på den anden NAS.

tubatuba
Bruger
Indlæg: 7
Tilmeldt: 30. jun 2017, 23:22

Re: Rsync fejl, ADM 2.7.3

Indlægaf tubatuba » 11. jul 2017, 18:53

Blueeyez skrev:Under Understøt krypteret overførsel via SSH skal du angive root som brugernavn. Kodeordet er det samme som ved admin på den anden NAS.


Mener jeg at have prøvet, men jeg prøver lige igen her senere i aften :)

Blueeyez
Site Admin
Indlæg: 95
Tilmeldt: 25. maj 2017, 13:17

Re: Rsync fejl, ADM 2.7.3

Indlægaf Blueeyez » 11. jul 2017, 19:40

Vil godt hjælpe over teamviewer eller anydesk hvis det fortsat ikke lykkes ;-)